Why is SSL/HTTPS not working on my site?

There can be several reasons why SSL/HTTPS is not working on your site. Please see if one of the causes listed below helps to solve your issue.

  • Are you using our name server ?
  • How to Solve the Invalid SSL /TLS Certificate Issue ?
  • How to Solve the Invalid SSL /TLS Certificate Issue ?

In Apache config:

<VirtualHost *:443>
ServerAdmin admin@discuss.mfoda-eg.com
ServerName mfoda-eg.com
ServerAlias www.mfoda-eg.com discuss.mfoda-eg.com mfoda-eg.com

            DocumentRoot /home/mydomain/repos/mydomain.com/public
            <Directory /home/mydomain/repos/mydomain.com/public>
                    Allowoverride All
                    Options FollowSymLinks
                    Require all granted
            </Directory>

            CustomLog ${APACHE_LOG_DIR}/access.log combined
            ErrorLog ${APACHE_LOG_DIR}/error.log

    SSLCertificateFile /etc/letsencrypt/live/discuss.mfoda-eg.com/fullchain.pem
    SSLCertificateKeyFile /etc/letsencrypt/live/discuss.mfoda-eg.com/privkey.pem

    Include /etc/letsencrypt/options-ssl-apache.conf
    </VirtualHost>
    </IfModule>

    Certificate Name: mfoda-eg.com
        Domains: mfoda-eg.com
       
        Certificate Path: /etc/letsencrypt/live/discuss.mfoda-eg.com/fullchain.pem
        Private Key Path: /etc/letsencrypt/live/discuss.mfoda-eg.com/privkey.pem

In nginx confg:

  server {
    listen 80;
    root /var/www/html;

    # Add index.php to the list if you are using PHP
    index index.html index.htm index.nginx-debian.html;

    server_name mfoda-eg.com www.mfoda-eg.com;

    location /.well-known {
            alias mfoda-eg.com;
            allow all;
            default_type "text/plain";
            autoindex    on;
            }
            location / {
            return 301 https://discuss.mfoda-eg.com$request_uri;
            }
}

  server {

   listen [::]:443 ssl ipv6only=on; # managed by Certbot
   server_name mfoda-eg.com www.mfoda-eg.com;

    ssl_certificate /etc/letsencrypt/live/discuss.mfoda-eg.com/fullchain.pem; # managed by Certbot
    ssl_certificate_key /etc/letsencrypt/live/discuss.mfoda-eg.com/privkey.pem; # managed by
    Certbot
    include /etc/letsencrypt/options-ssl-nginx.conf; # managed by Certbot
    ssl_dhparam /etc/letsencrypt/ssl-dhparams.pem; # managed by Certbot

        location / {
          proxy_pass "https://192.163.9.89:9090/admin/login";
        }
        }

SSL test again :